テーブル画面での操作 [Runtime以上]

概要

テーブル形式の表示画面では、複数のレコードを同時に表示できるため、同一列となる項目項目の値を比較しながらデータの入力や修正が可能です。テーブルに表示されたデータを操作するために、列メニューにさまざまな機能が設定されています。ソートやフィルタ、グループ化などを行なうためには、列メニューからそれらの機能を選択してください。

テーブル画面での基本操作

セルの選択

任意のセルをマウスで選択することにより、対象レコード、対象項目がそれぞれ行と列として強調表示されます。カーソル移動キー(矢印キー)によって、選択セルを移動できます。行ヘッダ、列ヘッダを選択すると、行のみの選択、列のみの選択とできます。また、パネルヘッダをクリックすることで、選択を解除できます。

「行」メニュー

カーソル移動

選択されたセルを移動するには、カーソルキーを使います。また、エンターキー、またはタブキーで移動することもできます。

エンターキーを押すと、選択セルが次の行へ、シフトキーを押しながらエンターキーを押すと、選択セルが前の行へ移動します。また、タブキーを押すと、選択セルが右の項目へ、シフトキーを押しながらタブキーを押すと、選択セルが左の項目へ移動します。

「行」メニュー

ページスクロール

テーブル上にすべてのレコードが表示しきれない場合には、パネル右側にスクロールバーが表示されます。このとき、[PageUp]キー、[PageDown]キーを押すことで、ページ単位で画面上のレコードをスクロールさせることができます。

データ入力(修正)

編集モード切替によって編集モードとなっている場合で、かつ項目が編集許可となっている場合(表示色が薄い黄色となっている場合)は、セルから直接データ入力が可能です。入力されたデータは、カーソルた他のセルに移動した時点で反映されます。

「行」メニュー

レコード追加

簡易追加モードの場合、最終行が選択されていて、かつコントロールキーを押しながらエンターキーを押す、新しいレコードが追加されます。また、簡易追加モードの場合、最終行の次の行をマウスでクリックした場合にも、新しいレコードが追加されます。

「行」メニュー

レコード削除

簡易削除モードの場合、行が選択されている状態(列は選択されていない状態)で[Delete]キーを押すと、選択しているレコードが削除されます。

「行」メニュー

列の表示幅の変更

列ヘッダの境界部分をマウスで選択し、マウス左ボタンを押した状態で左右に移動することで、列の表示幅を変更できます。また、列ヘッダの境界部分をマウスでダブルクリックすることで、その時点で表示されている項目データのサイズにあわせて列の表示幅を自動設定できます。

「行」メニュー

行メニュー

コンテキサーの操作画面で、行ヘッダの部分を右クリックすると、行メニューが表示されます。これによって、データの追加、修正、削除ができます。

「行」メニュー
図 「行」メニュー
表 行メニューの説明
番号 項目 説明
1 行ヘッダ この部分を右クリックすると行メニューが表示されます。
2 複製 選択された行のレコードの内容を複製し、新しいレコードとして追加します。
3 削除 選択された行のレコードを削除します。
4 テーブルヘッダ この部分を右クリックすると、テーブルメニューが表示されます。
5 挿入 新しいレコードを1行追加します。

列メニュー

「列」メニューには、次の項目があります。それぞれについて、説明します。

列メニュー
図 列メニュー
表 列メニューの説明
番号 項目 説明
1 列ヘッダ この部分をマウスで右クリックすると項目メニューが表示されます。
2 昇順 選択した項目の値が昇順になるようにデータを並び替えます。
3 降順 選択した項目の値が降順になるようにデータを並び替えます。
4 フィルタ 選択した項目についてフィルタ条件を指定して対象を絞り込みます。文字列の場合は、指定した文字が含まれているものが対象となります。
5 グループ 選択した項目について、同一のデータをグループ化し、それぞれの列を集計します。
6 表示条件の解除 選択した項目に関する表示条件(ソートとフィルタ)を解除します。表示条件によって非表示となっていたレコードがすべて表示されます。
7 設定画面 選択した項目の項目設定画面を表示します。
(Runtime版では表示されません)
8 項目削除 選択した項目の定義を削除にします。
(Runtime版では表示されません)
9 隠す 選択した項目をパネル上で非表示にします。非表示とした項目を再び表示するには、パネルの項目一覧画面で「表示」列をチェックします。
(Runtime版では表示されません)

レコードのソート

表形式に表示されたレコードの順を特定の項目の値によって昇順、または降順にソートするには、列メニューの「昇順」または「降順」を選択します。

ソートによって並べ替えられた順に対して、続けて別のソートを実行した場合に、直前の並びが第二優先として採用されます。つまり、指定した項目の値が等しい場合には、この第二優先の順位によって、最終的な並び順が決定されます。

グループ化機能

グループ化機能とは、コンテキストが持つレコードについて、指定した項目の値が等しいものをまとめる機能です。現在対象となっているレコードの中で、指定した項目の値が等しいものを1行にまとめ、すべての組み合わせについてリストアップします。グループ化によって重複したレコードを除外できるため重複したレコードを整理したい場合や、特定の値であるレコード件数を一度にカウントしたい場合などに利用できます。

例えば、コンテキストで「項目A」の値が「YES」のものと「NO」であるレコードがあり、「項目B」の値が「A」,「B」,「C」の3つある場合に、「項目A」と「項目B」の2つの項目をグループ化した場合には、存在するレコードの組み合わせで最大6行のレコードにまとめて表示します。

表 グループ化による「項目A」と「項目B」の組み合わせ
項目A 項目B
YES A
YES B
YES C
NO A
NO B
NO C

グループ化機能を実行するためには、グループ化したい項目の列メニューを表示し、その中から「グループ」を選択します。対象となる項目のすべての種類が表示されます。複数のレコードをグループ化するにあたっては、グループに属するそれぞれのレコードの項目の値は、あらかじめ指定された演算方法で集計されます。

グループ化による集計

グループ化した場合に、グループ化の対象以外の項目については、複数のレコードが持つ値を集計することになります。この集計方法は、あらかじめ各項目で設定しておきます。集計方法には、「上書き」,「合計」,「最大値」,「最小値」があり、既定値では「上書き」です。例えば、データ型が数値の項目で、集計方法を「合計」に設定すると、同じグループ内のその項目の値を合計した値で集計されます。

また、主キーに対応する項目については、常にグループごとのメンバー数(同一グループとなったレコードの数)が表示されます。これにより、各グループについて重複があるか、あるいは各グループの構成数がどのようになっているかを一覧で表示できます。

グループ化の組合せ

複数の項目に対してグループ化を指定した場合には、グループ化機能は、それらの項目の組合せに対してグループ化します。グループ化の項目は最大3つまで指定でき、4つ目を指定しようとすると、過去古い指定から順に取り消されます。

なお、グループ化機能とソート機能は同時に指定できません。また、グループ化された表形式上の各列は、実在しないレコードであるため、値の修正はできません。

データメニュー

データ編集モードのときに、データ表示部分で右クリックすると、次のように、インスタントフィルタ用のメニューの他に、貼り付け、そして値削除のメニューが表示されます。

図 データメニュー
表 データメニューの説明
項目 説明
貼り付け クリップボードにコピーされたデータがある場合、その値が貼り付けられます。Excelにおいて、表形式でコピーされた場合には、その表の縦×横のサイズのデータがそのままセルを超えて貼り付けられます。
値の削除 このセルの値をnull (値がない状態)にします。
この値でフィルタ インスタントフィルタにより、この項目をセルの値でレコードをフィルタします。

表形式データの貼り付け

Excelなど、表形式(縦横のマトリクス形式)のデータをクリップボードにコピーした場合、テーブル上で貼り付けが可能です。表形式データの貼り付けの場合は、貼り付け範囲の右上に相当するセルにおいて、データメニューの貼り付けを選択します。ただし、データ形式や編集許可などによって、部分的に値が変更できない場合があります。

インスタントフィルタ

フィルタバーを利用するフィルタに対して、列メニューにあるフィルタを選択し、フィルタ値を入力する方法をインスタントフィルタと呼びます。インスタントフィルタでは、指定した値を持つレコードのみがテーブルに表示されます。

インスタントフィルタは、セルメニューから実行することができます。次の図のように、対象とする値のセルにマウスを移動し右クリックして、「この値でフィルタ」を選択することでインスタントフィルタが適用されます。

図 インスタントフィルタ

インスタントフィルタにより、コンテキストのテーブル上に表示されるレコードが限定されている状態を解除するには、列メニューの「表示条件の解除」を選択します。この場合、対象とした項目に対するフィルタが解除されます。フィルタ条件が適用された項目には、項目名を表す列ヘッダに右下に斜線のマークが表示されます。

「行」メニュー

また、すべての項目に対するフィルタの限定を解除するには、メニューの「表示」→「全データ表示」を選択してください。

なお、フィルタが適用されている状態で、新しいレコードを追加すると、フィルタを指定した項目にフィルタ条件の値が初期値として入力されます。

補助画面の利用

補助画面を利用することで、レコードの値を容易に入力できます。パネルタイトルの右端に補助画面ボタンがある場合には、補助画面を利用できます。補助画面に表示されたレコードを入力フォームまたは表形式に反映させる方法は次の2通りあります。

レコードの上書き

補助画面上で該当するレコードをダブルクリックすると、あらかじめ設定された項目項目が現在の値に上書きされます。修正モードの場合には、選択されているレコードが修正になります。追加モードの場合には、入力フォーム上の該当する項目の値が変更になります。

レコードの追加

ドラッグ&ドロップが許可された補助画面の場合には、編集モードの場合には、補助画面の行ヘッダをドラッグし表形式上にドロップすることで、選択したレコードの内容が新規に追加されます。

図 補助画面を使ったデータの追加

 

表 補助画面を使ってデータを追加する手順
No 説明
1 補助画面である品目マスタをクリックすると、補助画面が表示されます。
2 入力モードに変更します。
3 ドラッグ&ドロップでデータを挿入します。
4 ダブルクリックで選択レコードを修正することもできます。

 

2016年11月18日 更新